[Bastion] 從 SSH Key 到 IAM:AWS SSM Shell 與 Port Forwarding

傳統 SSH Bastion: Shell | PortForwarding AWS – SSM: Sehll | SSH over SSM | Port Forwarding Introduction Bastion host – Wikipedia Bastion Host(堡壘主機,常被稱為跳板機)是部署在網路邊界(如公有子網或 DMZ)、經過加固的專用伺服器,作為從外部進入內部私有網路(Private Subnet)的單一受控入口。 核心功能與特點 單一入口:沒有公開 IP 的內部資源(如資料庫、應用程式伺服器)無法從外部直接連線,需先經過 Bastion Host,再透過 SSH、RDP 或 Port Forwarding(SSH Tunnel)存取。 縮小攻擊面:只開放必要服務(如 SSH),並透過最小化套件、關閉密碼登入、定期更新等方式加固。由於它直接暴露在外,本身也是高價值的攻擊目標。 集中管理與稽核:所有遠端存取集中在單一節點,方便記錄與追蹤;但需額外設定(如個人帳號、session […]

[HTTP] API Timeout 指南 (connect / read timeout)

Intro 關於 API Timeout 的網路資料略顯不足,Wikipedia 目前也只有廣義 Timeout (computing) 資訊。 本篇將分享個人對 Timeout 的所知,如有錯誤歡迎告知修正 Timeout 定義 Client Connect Timeout Read Timeout TCP Client TCP handshake 中從發出 SYN 到收到 SYN-ACK 完成三次握手的時間 指送出 PSH-ACK (Data) 後,每次資料封包 (Payload) 到達間的間隔 HTTP Client 包含 TCP 三次握手。是否包含 DNS […]

[SMTP] 簡易郵件傳輸通訊協定 SMTP (Simple Mail Transfer Protocol) 指南

Intro 簡易郵件傳輸通訊協定 SMTP 是什麼? | Cloudflare 簡單郵件傳送協定(Simple Mail Transfer Protocol / SMTP)可用在傳送和接收電子郵件的資訊,但 SMTP 通常用作傳送電子郵件而不是接收。 SMTP 是一個相對簡單的基於文字的協定,可以透過協定指定將訊息傳送至一或多個接收者,通過 telnet 程式可以簡單的測試一個 SMTP伺服器。SMTP 主要 TCP port 以前為 25 現今為 587 (TLS) 。DNS 的 MX record 決定 SMTP 伺服器。 角色 Agent Software for example MUA […]

[GEO] ESRI Shapefile (.shp .shx .dbf .prj) 空間資料開放格式

Intro Shapefile – Wikipedia ESRI Shapefile(shp)是美國環境系統研究所公司(ESRI)開發的空間資料開放格式。目前該檔案格式已經成為了地理訊息軟體界的開放標準,是重要的交換格式,能夠在ESRI與其他公司的產品之間進行資料互操作。 Tools mapshaper 可以將 Shapefile 轉成 GEO JSON,以便倒入如 Elastic Search 或 MongoDB 等 Index Storage。 mbloch/mapshaper: Tools for editing Shapefile, GeoJSON, TopoJSON and CSV files – GitHub mapshaper online

[DNS] CAA – Certification Authority Authorization 指南

Intro DNS CAA (DNS憑證頒發機構授權) – Wikipedia RFC 6844 通過域名持有人指定其域名的白名單憑證頒發機構來實現的安全機制。 該政策透過一個新的域名系統資源記錄(Record)「CAA」來實現,Record範例如下: example.com. CAA 0 issue “ca.example.net” 設定 首先 DNS records 要能夠支援 CAA record 再來針對憑證機構產生及設定 CAA record 即可,以下範例以 Letss Encrypt 機構為例: example.com. CAA 0 issue “letsencrypt.org” CAA Record Helper – CAA資源記錄產生器 References […]

[JWT] JSON Web Token 指南

JWT | JWS | JWE | JWK Intro JWT (JSON Web Token) 是一種基於 JSON 的開放標準(RFC 7519),它定義了一種簡潔(compact)且自包含(self-contained)的方式,用於在雙方之間安全地將訊息作為 JSON 物件傳輸。而這個訊息是經過數位簽章(Digital Signature),因此可以被驗證及信任。可以使用 密碼(經過 HMAC 演算法) 或用一對 公鑰/私鑰(經過 RSA 或 ECDSA 演算法) 來對 JWT 進行簽章。 Wiki – JSON Web Token RFC 7515 – JSON […]

[Encrypt][Asymmetric] 公開金鑰加密(非對稱式) – Public-key Cryptography

標準與格式 | 金鑰檢查 | 非對稱式金鑰產生 加解密/簽驗章實作 | 公鑰加密/私鑰解密 | 私鑰加密/公鑰解密 | 簽章/驗章 PKCS#1 | PKCS#8 | X.509 | PKCS#7 | PKCS#12 Intro Public-key cryptography OpenSSL commands OpenBSD manual page server – SSH-KEYGEN 標準與格式 編碼格式 格式 檔案內容 副檔名 標準來源 DER (Distinguished […]

[Dict] Golden Dict 跨平台多格式支援開源字典

Intro Golden Dict官網 Golden Dict GitHub 字典來源 – StarDict Dictionaries 中文字典 – 字典來源 – StarDict Dictionaries 安裝 Windows 直接至官網Download頁面下載即可。 MacOS 官方GitHub Wiki:Early Access Builds for Mac OS X 字典 字典檔的Source可以參考Intro連結。 字典的安裝預設路徑: ./GoldenDict/content 安裝完成後即可Rescan取得進行設定。 MacOS可以進入程式套件資料夾內MacOS/content加入路徑設定掃描